summary refs log tree commit diff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-11-08 09:12:43 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-11-08 09:12:43 +0100
commit2e2d88539ceb52369c0f20566786603f4d368c94 (patch)
tree1a7b21ede625cd35001b1053b7fd42417a7b08d8 /gnu/packages/bioinformatics.scm
parent179416467fce3b66fa4746e3ed92795b27e1f192 (diff)
downloadguix-2e2d88539ceb52369c0f20566786603f4d368c94.tar.gz
gnu: sra-tools: Use INVOKE.
* gnu/packages/bioinformatics.scm (sra-tools)[arguments]: Use INVOKE and
return #T unconditionally.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index b453b46873..2947b51d03 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -5712,8 +5712,7 @@ sequence itself can be retrieved from these databases.")
 
              ;; The 'configure' script doesn't recognize things like
              ;; '--enable-fast-install'.
-             (zero? (system*
-                     "./configure"
+             (invoke "./configure"
                      (string-append "--build-prefix=" (getcwd) "/build")
                      (string-append "--prefix=" (assoc-ref outputs "out"))
                      (string-append "--debug")
@@ -5731,7 +5730,8 @@ sequence itself can be retrieved from these databases.")
                      (string-append "--with-ngs-sdk-prefix="
                                     (assoc-ref inputs "ngs-sdk"))
                      (string-append "--with-hdf5-prefix="
-                                    (assoc-ref inputs "hdf5"))))))
+                                    (assoc-ref inputs "hdf5")))
+             #t))
          ;; This version of sra-tools fails to build with glibc because of a
          ;; naming conflict.  glibc-2.25/include/bits/mathcalls.h already
          ;; contains a definition of "canonicalize", so we rename it.