summary refs log tree commit diff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-05-19 12:23:04 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-05-19 16:10:47 +0300
commit58614c9b4bba93773adbc502df202ae980b01eae (patch)
treed18e538b2f4db2ea82d81b8a425f54534b5a883b /gnu/packages/bioinformatics.scm
parentdd03be186adb64bdb77265dfd0ad53fe50ec016e (diff)
downloadguix-58614c9b4bba93773adbc502df202ae980b01eae.tar.gz
gnu: samtools: Fix build on i686-linux.
* gnu/packages/bioinformatics.scm (samtools)[arguments]: When building
for i686-linux adjust the make-flags to specifically use the sse math
libraries.

Change-Id: I322d521cbe87e10db7c23db8e68bb377db966aa7
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 6aa35710e5..99db702dbf 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -9468,6 +9468,11 @@ to the user's query of interest.")
     (build-system gnu-build-system)
     (arguments
      `(#:configure-flags (list "--with-ncurses")
+       ;; The samtools test suite (and software) expects SSE-based math, even on
+       ;; i686-linux, and not 387-based math.  Adjust the CPPFLAGS accordingly.
+       ,@(if (target-x86-32?)
+             `(#:make-flags (list "CPPFLAGS = -msse -mfpmath=sse"))
+             '())
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'patch-tests