summary refs log tree commit diff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-02-06 21:24:42 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-02-06 21:32:16 +0100
commit6df215f8c8ad0ed4afd8c32a0414cf2ac7ec8983 (patch)
treed95ae91b1719472e639f1ecfab5457aae8d2a882 /gnu/packages/bioinformatics.scm
parentd11840b43ed2e0174b6012f1aeefb4c910c8c6c4 (diff)
downloadguix-6df215f8c8ad0ed4afd8c32a0414cf2ac7ec8983.tar.gz
gnu: star: Update to 2.7.0b.
* gnu/packages/bioinformatics.scm (star): Update to 2.7.0b.
[arguments]: Add "add-missing-header" build phase.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 23eba74175..516a7c1ee1 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -6020,7 +6020,7 @@ application of SortMeRNA is filtering rRNA from metatranscriptomic data.")
 (define-public star
   (package
     (name "star")
-    (version "2.7.0a")
+    (version "2.7.0b")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -6029,7 +6029,7 @@ application of SortMeRNA is filtering rRNA from metatranscriptomic data.")
               (file-name (string-append name "-" version "-checkout"))
               (sha256
                (base32
-                "1yx28gra6gqdx1ps5y8mpdinsn8r0dhsc2m3gcvjfrk71i9yhd6l"))
+                "1lih6cbpvnvhyvvswdhy06mwyzvwax96m723378v4z6psqzsh11d"))
               (modules '((guix build utils)))
               (snippet
                '(begin
@@ -6055,6 +6055,13 @@ application of SortMeRNA is filtering rRNA from metatranscriptomic data.")
                (("(COMPILATION_TIME_PLACE=\")(.*)(\")" _ pre mid post)
                 (string-append pre "Built with Guix" post)))
              #t))
+         ;; See https://github.com/alexdobin/STAR/pull/562
+         (add-after 'enter-source-dir 'add-missing-header
+           (lambda _
+             (substitute* "SoloReadFeature_inputRecords.cpp"
+               (("#include \"binarySearch2.h\"" h)
+                (string-append h "\n#include <math.h>")))
+             #t))
          (add-after 'enter-source-dir 'do-not-use-bundled-htslib
            (lambda _
              (substitute* "Makefile"