summary refs log tree commit diff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-01-23 21:22:45 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-23 21:22:45 +0100
commitf7373261e918b9601ae9f18db770fb0b0ac3999c (patch)
treeb3b089973fdb3ce5bc0a947bb8b451df450ab5fe /gnu/packages/bioinformatics.scm
parent469405375c84fcfff5822c0506f4ee5832d5f99d (diff)
downloadguix-f7373261e918b9601ae9f18db770fb0b0ac3999c.tar.gz
gnu: Add python-fcsparser.
* gnu/packages/bioinformatics.scm (python-fcsparser): New variable.

Change-Id: I87ed7f10bbfdf7d689cb6289a5f5ad31872f9de0
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index c87e91826c..ec076b783e 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4767,6 +4767,25 @@ result, LS-GKM achieves considerably higher accuracy than the original
 gkm-SVM.")
     (license license:gpl3+)))
 
+(define-public python-fcsparser
+  (package
+    (name "python-fcsparser")
+    (version "0.2.8")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "fcsparser" version))
+       (sha256
+        (base32 "1skk1k8phq9sj4ar0cnq8px89y3kcyh5zrbl6anz9wcdcyzkc16z"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-numpy python-pandas))
+    (native-inputs (list python-poetry-core python-pytest))
+    (home-page "https://github.com/eyurtsev/fcsparser")
+    (synopsis "Package for reading raw fcs files")
+    (description
+     "This package provides a Python package for reading raw fcs files")
+    (license license:expat)))
+
 (define-public python-pybigwig
   (package
     (name "python-pybigwig")