summary refs log tree commit diff
path: root/gnu/packages/bootloaders.scm
diff options
context:
space:
mode:
authorHerman Rimm <herman@rimm.ee>2024-01-18 17:11:02 +0100
committerVagrant Cascadian <vagrant@debian.org>2024-01-18 10:18:00 -0800
commit3e3975275bbab84d58f7740e9680b265769aa580 (patch)
treec285f44e6ec01dafe83103b4926e495a64af4a33 /gnu/packages/bootloaders.scm
parenta7a0b5dc59fc5f877d5aaf468667d1b8c35c33bb (diff)
downloadguix-3e3975275bbab84d58f7740e9680b265769aa580.tar.gz
gnu: u-boot: Update to 2024.01.
* gnu/packages/bootloaders.scm (u-boot): Update to 2024.01.
[source]: Remove patman patch, add build-without-libcrypto patch.
* gnu/packages/patches/u-boot-allow-disabling-openssl.patch: Remove
upstreamed diffs.
* gnu/packages/patches/u-boot-build-without-libcrypto.patch: Add file.
* gnu/packages/patches/u-boot-patman-change-id.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Add patch, remove patch.

Change-Id: I5a21d4cd645449ff669f17cdabe5313870bec46f
Signed-off-by: Vagrant Cascadian <vagrant@debian.org>
Diffstat (limited to 'gnu/packages/bootloaders.scm')
-rw-r--r--gnu/packages/bootloaders.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index c73a0e665d..986f0ac035 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -716,22 +716,26 @@ tree binary files.  These are board description files used by Linux and BSD.")
   ;; https://lists.denx.de/pipermail/u-boot/2021-October/462728.html
   (search-patch "u-boot-allow-disabling-openssl.patch"))
 
+(define %u-boot-build-without-libcrypto-patch
+  ;; Upstream commit to fix Amlogic builds in u-boot 2024.01.
+  (search-patch "u-boot-build-without-libcrypto.patch"))
+
 (define u-boot
   (package
     (name "u-boot")
-    (version "2023.10")
+    (version "2024.01")
     (source (origin
               (patches
                (list %u-boot-rockchip-inno-usb-patch
-                     %u-boot-allow-disabling-openssl-patch
-                     (search-patch "u-boot-patman-change-id.patch")))
+                     %u-boot-build-without-libcrypto-patch
+                     %u-boot-allow-disabling-openssl-patch))
               (method url-fetch)
               (uri (string-append
                     "https://ftp.denx.de/pub/u-boot/"
                     "u-boot-" version ".tar.bz2"))
               (sha256
                (base32
-                "0039rravvjq9yi41645fynycw4c869px024xfc0n212f05pnq3p0"))))
+                "1czmpszalc6b8cj9j7q6cxcy19lnijv3916w3dag6yr3xpqi35mr"))))
     (build-system gnu-build-system)
     (native-inputs
      (list bison