summary refs log tree commit diff
path: root/gnu/packages/bootloaders.scm
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@debian.org>2019-01-16 15:21:52 -0800
committerDanny Milosavljevic <dannym@scratchpost.org>2019-02-04 00:21:48 +0100
commit4da4e952ddf9823d115997dbfa3bb45c74ac7463 (patch)
treec109e80caee81480463b7366facfd85607ab0389 /gnu/packages/bootloaders.scm
parentc7797b75cc648489b811bc7b9485fb4e0cb79173 (diff)
downloadguix-4da4e952ddf9823d115997dbfa3bb45c74ac7463.tar.gz
gnu: u-boot: Update to 2019.01.
* gnu/packages/bootloaders.scm (u-boot): Update to 2019.01.
(u-boot-tools): Disable CONFIG_SOUND in sandbox configs.
(u-boot-pinebook)[source]: Remove patches.
* gnu/packages/patches/u-boot-pinebook-a64-update-dts.patch,
gnu/packages/patches/u-boot-pinebook-dts.patch,
gnu/packages/patches/u-boot-pinebook-mmc-calibration.patch,
gnu/packages/patches/u-boot-pinebook-r_i2c-controller.patch,
gnu/packages/patches/u-boot-pinebook-syscon-node.patch,
gnu/packages/patches/u-boot-pinebook-video-bridge.patch: Delete files.
* gnu/local.mk (dist_patch_DATA): Adjust as necessary.
Diffstat (limited to 'gnu/packages/bootloaders.scm')
-rw-r--r--gnu/packages/bootloaders.scm24
1 files changed, 8 insertions, 16 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 0fbf481893..5bd784f73c 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -376,7 +376,7 @@ tree binary files.  These are board description files used by Linux and BSD.")
 (define u-boot
   (package
     (name "u-boot")
-    (version "2018.11")
+    (version "2019.01")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -384,7 +384,7 @@ tree binary files.  These are board description files used by Linux and BSD.")
                     "u-boot-" version ".tar.bz2"))
               (sha256
                (base32
-                "0znkwljfwwn4y7j20pzz4ilqw8znphrfxns0x1lwdzh3xbr96z3k"))))
+                "08hwsmh5xsb1gcxsv8gvx00bai938dm5y3889n8jif3a8rd7xgah"))))
     (native-inputs
      `(("bc" ,bc)
        ("bison" ,bison)
@@ -440,6 +440,11 @@ also initializes the boards (RAM etc).")
               (("def test_ctrl_c")
                "@pytest.mark.skip(reason='Guix has problems with SIGINT')
 def test_ctrl_c"))
+             ;; This test requires a sound system, which is un-used in u-boot-tools.
+             (for-each (lambda (file)
+                              (substitute* file
+                                  (("CONFIG_SOUND=y") "CONFIG_SOUND=n")))
+                              (find-files "configs" "sandbox_.*defconfig$"))
              #t))
          (replace 'configure
            (lambda* (#:key make-flags #:allow-other-keys)
@@ -595,20 +600,7 @@ board-independent tools.")))
   (make-u-boot-sunxi64-package "pine64_plus" "aarch64-linux-gnu"))
 
 (define-public u-boot-pinebook
-  (let ((base (make-u-boot-sunxi64-package "pinebook" "aarch64-linux-gnu")))
-    (package
-      (inherit base)
-      (source (origin
-              (inherit (package-source u-boot))
-              (patches (search-patches
-                        ;; Add patches to enable Pinebook support from sunxi
-                        ;; maintainer tree: git://git.denx.de/u-boot-sunxi.git
-                        "u-boot-pinebook-a64-update-dts.patch"
-                        "u-boot-pinebook-syscon-node.patch"
-                        "u-boot-pinebook-mmc-calibration.patch"
-                        "u-boot-pinebook-video-bridge.patch"
-                        "u-boot-pinebook-r_i2c-controller.patch"
-                        "u-boot-pinebook-dts.patch")))))))
+  (make-u-boot-sunxi64-package "pinebook" "aarch64-linux-gnu"))
 
 (define-public u-boot-bananapi-m2-ultra
   (make-u-boot-package "Bananapi_M2_Ultra" "arm-linux-gnueabihf"))