summary refs log tree commit diff
path: root/gnu/packages/bootloaders.scm
diff options
context:
space:
mode:
authorHerman Rimm <herman@rimm.ee>2023-11-27 09:33:47 +0100
committerVagrant Cascadian <vagrant@debian.org>2023-12-22 16:05:50 -0800
commitfad93748cd2d44f7f68d2d973a22ed0b438e657b (patch)
tree652b1fcf89b6af92f1bd5a17a4f9da4b33b8c4ad /gnu/packages/bootloaders.scm
parent892ec53b7eedf998afa149b9cdd169f0cab8f41d (diff)
downloadguix-fad93748cd2d44f7f68d2d973a22ed0b438e657b.tar.gz
gnu: u-boot: Update to 2023.10.
* gnu/local.mk: De-register patches.
* gnu/packages/bootloaders.scm (u-boot): Update to 2023.10.
[source]: Remove patches.
(u-boot-documentation)[inputs]: Add python-sphinx-prompt.
* gnu/packages/patches/u-boot-allow-disabling-openssl.patch: Refresh.
* gnu/packages/patches/u-boot-fix-build-python-3.10.patch: Delete file.
* gnu/packages/patches/u-boot-fix-u-boot-lib-build.patch: Delete file.
* gnu/packages/patches/u-boot-rk3399-enable-emmc-phy.patch: Delete file.
* gnu/packages/patches/u-boot-rockchip-inno-usb.patch: Refresh.
* gnu/packages/patches/u-boot-sifive-prevent-reloc-initrd-fdt.patch:
  Delete file.

Modifed-by: Vagrant Cascadian <vagrant@debian.org>
Signed-off-by: Vagrant Cascadian <vagrant@debian.org>
Diffstat (limited to 'gnu/packages/bootloaders.scm')
-rw-r--r--gnu/packages/bootloaders.scm21
1 files changed, 4 insertions, 17 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index e708641623..d0df4f62c2 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -18,6 +18,7 @@
 ;;; Copyright © 2022, 2023 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
 ;;; Copyright © 2021 Stefan <stefan-guix@vodafonemail.de>
 ;;; Copyright © 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2023 Herman Rimm <herman@rimm.ee>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -692,34 +693,19 @@ tree binary files.  These are board description files used by Linux and BSD.")
   ;; and https://patchwork.ozlabs.org/project/uboot/patch/20210406151059.1187379-1-icenowy@aosc.io
   (search-patch "u-boot-rockchip-inno-usb.patch"))
 
-(define %u-boot-sifive-prevent-relocating-initrd-fdt
-  ;; Fix boot in 2021.07 on Hifive unmatched, see
-  ;; https://bugs.launchpad.net/ubuntu/+source/u-boot/+bug/1937246
-  (search-patch "u-boot-sifive-prevent-reloc-initrd-fdt.patch"))
-
 (define %u-boot-allow-disabling-openssl-patch
   ;; Fixes build of u-boot 2021.10 without openssl
   ;; https://lists.denx.de/pipermail/u-boot/2021-October/462728.html
   (search-patch "u-boot-allow-disabling-openssl.patch"))
 
-(define %u-boot-rk3399-enable-emmc-phy-patch
-  ;; Fix emmc boot on rockpro64 and pinebook-pro, this was a regression
-  ;; therefore should hopefully be fixed when updating u-boot.
-  ;; https://lists.denx.de/pipermail/u-boot/2021-November/466329.html
-  (search-patch "u-boot-rk3399-enable-emmc-phy.patch"))
-
 (define u-boot
   (package
     (name "u-boot")
-    (version "2023.07.02")
+    (version "2023.10")
     (source (origin
               (patches
                (list %u-boot-rockchip-inno-usb-patch
                      %u-boot-allow-disabling-openssl-patch
-                     %u-boot-sifive-prevent-relocating-initrd-fdt
-                     %u-boot-rk3399-enable-emmc-phy-patch
-                     (search-patch "u-boot-fix-build-python-3.10.patch")
-                     (search-patch "u-boot-fix-u-boot-lib-build.patch")
                      (search-patch "u-boot-patman-change-id.patch")))
               (method url-fetch)
               (uri (string-append
@@ -727,7 +713,7 @@ tree binary files.  These are board description files used by Linux and BSD.")
                     "u-boot-" version ".tar.bz2"))
               (sha256
                (base32
-                "1m91w3fpywllkwm000dqsw3294j0szs1lz6qbgwv1aql3ic4hskb"))))
+                "0039rravvjq9yi41645fynycw4c869px024xfc0n212f05pnq3p0"))))
     (build-system gnu-build-system)
     (native-inputs
      (list bison
@@ -778,6 +764,7 @@ also initializes the boards (RAM etc).")
      (modify-inputs (package-native-inputs u-boot)
        (append fontconfig
                python-sphinx
+               python-sphinx-prompt
                texinfo
                which)))
     (synopsis "U-Boot documentation")