summary refs log tree commit diff
path: root/gnu/packages/bootstrap.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-11-01 12:59:31 +0100
committerLudovic Courtès <ludo@gnu.org>2013-11-01 12:59:31 +0100
commitff8061b59161592690ab6ea526282fae11d87676 (patch)
tree09f00df03ec0a1f4922376ba1a0cd4f443a305e4 /gnu/packages/bootstrap.scm
parente50805251ae7386c2ddbd036885bcc4300cf336e (diff)
parentb645425f71a5a777e7658bbdac0e22e134d44db5 (diff)
downloadguix-ff8061b59161592690ab6ea526282fae11d87676.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/bootstrap.scm')
-rw-r--r--gnu/packages/bootstrap.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/bootstrap.scm b/gnu/packages/bootstrap.scm
index 86be880cfd..2a8af36ad6 100644
--- a/gnu/packages/bootstrap.scm
+++ b/gnu/packages/bootstrap.scm
@@ -80,14 +80,13 @@
       (patch-guile %bootstrap-guile)
       (patch-inputs %bootstrap-patch-inputs))))
 
-(define (package-from-tarball name* source* program-to-test description*)
-  "Return a package that correspond to the extraction of SOURCE*.
-PROGRAM-TO-TEST is a program to run after extraction of SOURCE*, to
+(define (package-from-tarball name source program-to-test description)
+  "Return a package that correspond to the extraction of SOURCE.
+PROGRAM-TO-TEST is a program to run after extraction of SOURCE, to
 check whether everything is alright."
   (package
-    (name name*)
+    (name name)
     (version "0")
-    (source #f)
     (build-system trivial-build-system)
     (arguments
      `(#:guile ,%bootstrap-guile
@@ -111,8 +110,9 @@ check whether everything is alright."
     (inputs
      `(("tar" ,(search-bootstrap-binary "tar" (%current-system)))
        ("xz"  ,(search-bootstrap-binary "xz" (%current-system)))
-       ("tarball" ,(bootstrap-origin (source* (%current-system))))))
-    (synopsis description*)
+       ("tarball" ,(bootstrap-origin (source (%current-system))))))
+    (source #f)
+    (synopsis description)
     (description #f)
     (home-page #f)
     (license #f)))