summary refs log tree commit diff
path: root/gnu/packages/bqn.scm
diff options
context:
space:
mode:
authorChristopher Rodriguez <yewscion@gmail.com>2022-08-10 13:27:57 -0400
committerLudovic Courtès <ludo@gnu.org>2022-09-01 00:57:09 +0200
commit7bae4f16503d2a901873cd0722c6675b6bb96595 (patch)
treeffbe1341b25a9273aa69a42e8e9620e31f22998e /gnu/packages/bqn.scm
parent9aa2a41b475ff04ed32cc450e8a9120e18720e83 (diff)
downloadguix-7bae4f16503d2a901873cd0722c6675b6bb96595.tar.gz
gnu: Add bqn-sources.
* gnu/packages/bqn.scm (bqn-sources): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/bqn.scm')
-rw-r--r--gnu/packages/bqn.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/bqn.scm b/gnu/packages/bqn.scm
index 4ca9f48a0e..8aef8c6bcd 100644
--- a/gnu/packages/bqn.scm
+++ b/gnu/packages/bqn.scm
@@ -109,3 +109,17 @@ not need to be bootstrapped, based on an earlier Java implementation of APL by
 the same author.")
       (home-page "https://github.com/dzaima/BQN")
       (license license:expat))))
+
+(define bqn-sources
+  ;; Aside from dbqn above, the main bqn repository is used by other
+  ;; implementations as a "known good" set of sources. CBQN uses dbqn to
+  ;; generate an intermediate bytecode for its own compilation.
+    (let ((commit "e219af48401473a7bac49bdd8b89d69082cf5dd8"))
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+              (url "https://github.com/mlochbaum/BQN")
+              (commit commit)))
+        (file-name (git-file-name "bqn-sources" commit))
+        (sha256
+         (base32 "0r6pa9lscl2395g4xlvmg90vpdsjzhin4f1r0s7brymmpvmns2yc")))))