summary refs log tree commit diff
path: root/gnu/packages/busybox.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-12-11 12:04:15 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-12-11 12:04:37 +0200
commit8f330aebee504269d4d7188daa85e95503f71888 (patch)
tree68c28e9bb258bb4cd5ce6d7dca3ef662142868cc /gnu/packages/busybox.scm
parentf765577dec0340d035021d030f17b54a3a5fd6b1 (diff)
downloadguix-8f330aebee504269d4d7188daa85e95503f71888.tar.gz
gnu: busybox: Update to 1.32.0.
* gnu/packages/busybox.scm (busybox): Update to 1.32.0.
[source]: Remove patch.
* gnu/packates/patches/busybox-1.31.1-fix-build-with-glibc-2.31.patch:
Remove file.
* gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/busybox.scm')
-rw-r--r--gnu/packages/busybox.scm11
1 files changed, 4 insertions, 7 deletions
diff --git a/gnu/packages/busybox.scm b/gnu/packages/busybox.scm
index 0a93c6475e..c931a2f2f7 100644
--- a/gnu/packages/busybox.scm
+++ b/gnu/packages/busybox.scm
@@ -1,6 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2014 John Darrington <jmd@gnu.org>
-;;; Copyright © 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -32,7 +32,7 @@
 (define-public busybox
   (package
     (name "busybox")
-    (version "1.31.1")
+    (version "1.32.0")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -40,10 +40,7 @@
                     version ".tar.bz2"))
               (sha256
                (base32
-                "1659aabzp8w4hayr4z8kcpbk2z1q2wqhw7i1yb0l72b45ykl1yfh"))
-              (patches
-               (search-patches
-                "busybox-1.31.1-fix-build-with-glibc-2.31.patch"))))
+                "12g63zsvzfz04wbyga8riyl8ils05riw4xf26cyiaasbs3qqfpf3"))))
     (build-system gnu-build-system)
     (arguments
      '(#:phases
@@ -90,7 +87,7 @@
              ;; true in guix build environment
              (substitute* "testsuite/pidof.tests"
                (("-s init") "-s $(cat /proc/1/comm)"))
-  
+
              ;; This test cannot possibly pass.
              ;; It is trying to test that "which ls" returns "/bin/ls" when PATH is not set.
              ;; However, this relies on /bin/ls existing.  Which it does not in guix.