summary refs log tree commit diff
path: root/gnu/packages/busybox.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-07-19 21:27:46 +0300
committerEfraim Flashner <efraim@flashner.co.il>2018-07-19 21:29:14 +0300
commite9ab4b40a8bf6ddf7242bc0d67b61148a4078419 (patch)
tree413613fe7aa6af81fb9584c5ccf8f3933ef6998e /gnu/packages/busybox.scm
parent83099892e0cf0d9c59f5e1a0774331026e48baa8 (diff)
downloadguix-e9ab4b40a8bf6ddf7242bc0d67b61148a4078419.tar.gz
gnu: busybox: Update to 1.29.1.
* gnu/packages/busybox.scm (busybox): Update to 1.29.1.
[arguments]: Add custom phase to change the default value of TASKSET.
Diffstat (limited to 'gnu/packages/busybox.scm')
-rw-r--r--gnu/packages/busybox.scm13
1 files changed, 10 insertions, 3 deletions
diff --git a/gnu/packages/busybox.scm b/gnu/packages/busybox.scm
index 4cdea3a294..480b777574 100644
--- a/gnu/packages/busybox.scm
+++ b/gnu/packages/busybox.scm
@@ -1,6 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2014 John Darrington <jmd@gnu.org>
-;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -31,7 +31,7 @@
 (define-public busybox
   (package
     (name "busybox")
-    (version "1.26.2")
+    (version "1.29.1")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -39,11 +39,18 @@
                     version ".tar.bz2"))
               (sha256
                (base32
-                "05mg6rh5smkzfwqfcazkpwy6h6555llsazikqnvwkaf17y8l8gns"))))
+                "1hqlr5b3bsyb6avadz1z4za6pyl32r1krnpcpwwqilhnx8q0f9gw"))))
     (build-system gnu-build-system)
     (arguments
      '(#:phases
        (modify-phases %standard-phases
+         (add-before 'configure 'disable-taskset
+           ;; This feature fails its tests in the build environment,
+           ;; was default 'n' until after 1.26.2.
+           (lambda _
+             (substitute* "util-linux/taskset.c"
+               (("default y") "default n"))
+             #t))
          (replace 'configure
            (lambda _ (invoke "make" "defconfig")))
          (replace 'check