summary refs log tree commit diff
path: root/gnu/packages/busybox.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-06-16 20:34:13 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-06-17 10:02:45 +0300
commitee0b4733e1a186048983ac6b6ba0bae23b3f567d (patch)
tree17cf991f7cfe0ba22059b9b1063d402808c255eb /gnu/packages/busybox.scm
parentc9f0331152268c90c7cf02a14c79f1ed7ef6c81a (diff)
downloadguix-ee0b4733e1a186048983ac6b6ba0bae23b3f567d.tar.gz
gnu: toybox: Don't install files to usr.
* gnu/packages/busybox.scm (toybox)[arguments]: Add custom phase to
remove any files installed in $PREFIX/usr.
Diffstat (limited to 'gnu/packages/busybox.scm')
-rw-r--r--gnu/packages/busybox.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/busybox.scm b/gnu/packages/busybox.scm
index cc6257ba35..182b8ac618 100644
--- a/gnu/packages/busybox.scm
+++ b/gnu/packages/busybox.scm
@@ -1,8 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2014 John Darrington <jmd@gnu.org>
-;;; Copyright © 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -133,7 +132,12 @@ any small or embedded system.")
              (let ((out (assoc-ref outputs "out")))
                (invoke "make"
                        (string-append "PREFIX=" out)
-                       "install")))))
+                       "install"))))
+         (add-after 'install 'remove-usr-directory
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out")))
+               (delete-file-recursively (string-append out "/usr"))
+               #t))))
        #:test-target "tests"))
     (native-inputs `(("bc" ,bc)))
     (synopsis "Many common UNIX utilities in a single executable")