summary refs log tree commit diff
path: root/gnu/packages/c.scm
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2021-10-18 17:33:07 +0000
committerLudovic Courtès <ludo@gnu.org>2021-11-16 16:59:50 +0100
commit1a0ed46097dfc41e74354c44bd410a97e41df785 (patch)
tree0238853921aafec28b9e63bb53379d8886e9e3a3 /gnu/packages/c.scm
parent4ff5cd6b0645a06a6542834f6ff83d725ce61b5c (diff)
downloadguix-1a0ed46097dfc41e74354c44bd410a97e41df785.tar.gz
gnu: aws-c-http: Update to 0.6.7.
* gnu/packages/c.scm (aws-c-http): Update to 0.6.7.
[arguments]: Fix CMAKE_PREFIX_PATH, disable network tests.
[source]: Remove patches.
* gnu/packages/patches/aws-c-http-cmake-prefix.patch,
gnu/packages/patches/aws-c-http-disable-networking-tests.patch:
Delete files.
* gnu/local.mk: Remove them.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/c.scm')
-rw-r--r--gnu/packages/c.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index a537988abe..2b80303170 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -719,7 +719,8 @@ low level functionality for coroutines.")
 (define-public aws-c-http
   (package
     (name "aws-c-http")
-    (version "0.6.4")
+    ; Update only when updating aws-crt-cpp.
+    (version "0.6.7")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -728,15 +729,14 @@ low level functionality for coroutines.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "18xlgz68zizkcp784bs6hkyx0gvp0f1p076i46z653bcd3qa87b4"))
-              (patches
-               (search-patches
-                "aws-c-http-cmake-prefix.patch"
-                "aws-c-http-disable-networking-tests.patch"))))
+                "1s06bz6w7355ldyhwjidcpbff7591ch4lwwjcj47a6k2kczdmiz4"))))
     (build-system cmake-build-system)
     (arguments
      '(#:configure-flags
-       '("-DBUILD_SHARED_LIBS=ON")))
+       (list "-DBUILD_SHARED_LIBS=ON"
+             (string-append "-DCMAKE_PREFIX_PATH="
+                            (assoc-ref %build-inputs "aws-c-common"))
+             "-DENABLE_NET_TESTS=OFF")))
     (propagated-inputs
      `(("aws-c-compression" ,aws-c-compression)
        ("aws-c-io" ,aws-c-io)))