summary refs log tree commit diff
path: root/gnu/packages/c.scm
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2021-03-04 12:19:50 +0000
committerLudovic Courtès <ludo@gnu.org>2021-03-12 23:58:54 +0100
commitcc95d03ec7aa2d4de2f880fdb0c9ccbf3343e041 (patch)
tree51e92e17dc1cc5977ec78550d8ab00c4d6edae80 /gnu/packages/c.scm
parent9d541e97e99793d0c75f01bc52de61473632e0ec (diff)
downloadguix-cc95d03ec7aa2d4de2f880fdb0c9ccbf3343e041.tar.gz
gnu: aws-checksums: Build as shared library.
* gnu/packages/c.scm (aws-checksums)[arguments]: Build as shared library.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/c.scm')
-rw-r--r--gnu/packages/c.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index 75fa6460be..1e338bd7bd 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -581,6 +581,9 @@ portability.")
                 "1pjs31x3cq9wyw511y00kksz660m8im9zxk30hid8iwlilcbnyvx"))
               (patches (search-patches "aws-checksums-cmake-prefix.patch"))))
     (build-system cmake-build-system)
+    (arguments
+     '(#:configure-flags
+       '("-DBUILD_SHARED_LIBS=ON")))
     (inputs
      `(("aws-c-common" ,aws-c-common)))
     (synopsis "Amazon Web Services checksum library")