summary refs log tree commit diff
path: root/gnu/packages/calendar.scm
diff options
context:
space:
mode:
authorLuís Henriques <henrix@camandro.org>2024-09-07 11:58:05 +0100
committerLudovic Courtès <ludo@gnu.org>2024-09-28 00:20:19 +0200
commit59f49fb55ab3971d3b08f31fb706c7a40bc84748 (patch)
tree85b667f7210c947b14711d976d86f9f0e56d69d3 /gnu/packages/calendar.scm
parentb21118a2df0f851832068dd5dc1e0b0706e2e38c (diff)
downloadguix-59f49fb55ab3971d3b08f31fb706c7a40bc84748.tar.gz
gnu: remind: Update to 05.00.05.
* gnu/packages/calendar.scm (remind): Update to 05.00.05.
[properties]: Add tcl output synopsis.
[arguments]<#:phases>: Update list of files to include in tcl output.
There's only one tcltk script now.
[native-inputs]: Add tzdata.

Change-Id: I729d48a8e538039ef5d8c9cb8bd232b3946b5f76
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/calendar.scm')
-rw-r--r--gnu/packages/calendar.scm38
1 files changed, 20 insertions, 18 deletions
diff --git a/gnu/packages/calendar.scm b/gnu/packages/calendar.scm
index 05c00df082..6717db867f 100644
--- a/gnu/packages/calendar.scm
+++ b/gnu/packages/calendar.scm
@@ -227,7 +227,7 @@ interface} named 'ikhal'.")
 (define-public remind
   (package
     (name "remind")
-    (version "3.3.7")
+    (version "5.0.5")
     (source
      (origin
        (method url-fetch)
@@ -238,7 +238,9 @@ interface} named 'ikhal'.")
                                         ".")
                            ".tar.gz"))
        (sha256
-        (base32 "0gca7f5gc0zr111c28hxw4hycz1hr9z7s912bpzm92g1s4llxjc7"))))
+        (base32 "0yc0lfrl0zzc1bn5fkigararg44bdryis7vjnm8vzs21as9r0dbz"))))
+    (properties
+     `((output-synopsis "tcl" "graphical front-end to Remind calendar program")))
     (build-system gnu-build-system)
     (outputs (list "out"
                    "tcl"))           ; more than doubles the closure by >110 MiB
@@ -255,24 +257,24 @@ interface} named 'ikhal'.")
                   (let ((from (string-append out "/" file))
                         (to   (string-append tcl "/" file)))
                     (mkdir-p (dirname to))
-                    (rename-file from to)
-                    ;; For simplicity, wrap all scripts with the same variables
-                    ;; even though, e.g., inetutils is not needed by cm2rem.tcl.
-                    ;; XXX Using WRAP-SCRIPT currently breaks tkremind.
-                    (wrap-program to
-                      `("PATH" ":" prefix
-                        ,(map (lambda (dir)
-                                (string-append dir "/bin"))
-                              (append (list out tcl)
-                                      (map (lambda (input)
-                                             (assoc-ref inputs input))
-                                           (list "tcl" "tk" "inetutils")))))
-                      `("TCLLIBPATH" " " =
-                        (,(getenv "TCLLIBPATH"))))))
-                (list "bin/cm2rem.tcl"
-                      "bin/tkremind"))))))))
+                    (rename-file from to)))
+                (list "bin/tkremind"
+                      "share/man/man1/tkremind.1"
+                      "share/pixmaps/tkremind.png"
+                      "share/applications/tkremind.desktop"))
+               (wrap-program (string-append tcl "/bin/tkremind")
+                 `("PATH" ":" prefix
+                   ,(map (lambda (dir)
+                           (string-append dir "/bin"))
+                         (append (list out tcl)
+                                 (map (lambda (input)
+                                        (assoc-ref inputs input))
+                                      (list "tcl" "tk" "inetutils")))))
+                 `("TCLLIBPATH" " " =
+                   (,(getenv "TCLLIBPATH"))))))))))
     (inputs
      (list bash-minimal inetutils tcl tcllib tk))
+    (native-inputs (list tzdata-for-tests))       ;required for some tests
     (home-page "https://dianne.skoll.ca/projects/remind/")
     (synopsis "Sophisticated calendar and alarm program")
     (description