summary refs log tree commit diff
path: root/gnu/packages/cdrom.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-12-27 23:51:38 +0100
committerLudovic Courtès <ludo@gnu.org>2018-12-28 00:30:03 +0100
commit842ffcfd2dc00c1911533dc7c68a3d7120fc23e0 (patch)
treeb3dd6c331a464f63303bf0a75b323d6de7497f15 /gnu/packages/cdrom.scm
parent5a7899fd88c1c463d3b75ac9077ccd183ddec914 (diff)
downloadguix-842ffcfd2dc00c1911533dc7c68a3d7120fc23e0.tar.gz
gnu: cdrtools: Do not record the kernel version.
This allows for reproducible builds across machines running different
versions of the kernel Linux.

* gnu/packages/cdrom.scm (cdrtools)[source](modules, snippet): New
fields.
Diffstat (limited to 'gnu/packages/cdrom.scm')
-rw-r--r--gnu/packages/cdrom.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/cdrom.scm b/gnu/packages/cdrom.scm
index 658d6c6bd5..c48f581576 100644
--- a/gnu/packages/cdrom.scm
+++ b/gnu/packages/cdrom.scm
@@ -225,6 +225,20 @@ reconstruction capability.")
               (sha256
                (base32
                 "03w6ypsmwwy4d7vh6zgwpc60v541vc5ywp8bdb758hbc4yv2wa7d"))
+              (modules '((guix build utils)))
+              (snippet
+               '(begin
+                  ;; By default 'cdda2wav --help' would print a string like
+                  ;; "Version 3.01_linux_4.19.10-gnu_x86_64_x86_64".  Change
+                  ;; it to not capture the kernel version of the build
+                  ;; machine, to allow for reproducible builds.
+                  (substitute* "cdda2wav/local.cnf.in"
+                    (("^VERSION_OS=.*")
+                     (string-append
+                      "actual_os := $(shell uname -o)\n"
+                      "actual_arch := $(shell uname -m)\n"
+                      "VERSION_OS = _$(actual_os)_$(actual_arch)\n")))
+                  #t))
               (patches (search-patches "cdrtools-3.01-mkisofs-isoinfo.patch"))))
     (build-system gnu-build-system)
     ;; XXX cdrtools bundles a modified, relicensed early version of cdparanoia.