summary refs log tree commit diff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-08-12 18:44:17 +0200
committerMarius Bakke <marius@gnu.org>2022-09-09 17:03:56 +0200
commit14a9996cc24dfedb6467896e0e43220322c148ff (patch)
tree22b15ab5dd9a403aa5c79c05871d030839df285e /gnu/packages/check.scm
parent6634ea9ff9eb2df78d42d354316b009a9b2ae903 (diff)
downloadguix-14a9996cc24dfedb6467896e0e43220322c148ff.tar.gz
gnu: python-pyfakefs: Update to 4.6.3.
* gnu/packages/check.scm (python-pyfakefs): Update to 4.6.3.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm13
1 files changed, 2 insertions, 11 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 5aecbd374b..8a83c88a04 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2972,7 +2972,7 @@ grew out of the @dfn{Vc} project.")
 (define-public python-pyfakefs
   (package
     (name "python-pyfakefs")
-    (version "3.7.1")
+    (version "4.6.3")
     (source (origin
               (method url-fetch)
               ;; We use the PyPI URL because there is no proper release
@@ -2981,22 +2981,13 @@ grew out of the @dfn{Vc} project.")
               (uri (pypi-uri "pyfakefs" version))
               (sha256
                (base32
-                "1cp2yw96fa2qkgi39xa3nlr3inf8wb5rgh9kdq53256ca2r8pdhy"))
+                "18bcv8yalg80zgigx40fk692yr3wf9ch1hkb0cdplqspyry2mwbd"))
               (patches (search-patches
                         "python-pyfakefs-remove-bad-test.patch"))
               (file-name (string-append name "-" version ".tar.gz"))))
     (arguments
      `(#:phases
        (modify-phases %standard-phases
-         (add-after 'unpack 'patch-testsuite
-           (lambda _
-             ;; Time difference is larger than expected.
-             (substitute* "pyfakefs/tests/fake_filesystem_unittest_test.py"
-               (("(\\s+)def test_copy_real_file" all indent)
-                (string-append
-                  indent
-                  "@unittest.skip('disabled by guix')\n"
-                  all)))))
          ;; The default test suite does not run these extra tests.
          (add-after 'check 'check-pytest-plugin
            (lambda _