summary refs log tree commit diff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-01-27 14:00:10 +0100
committerLudovic Courtès <ludo@gnu.org>2020-01-27 14:18:12 +0100
commit5e61de242156cdb3314abac168d9682ca7a4c28f (patch)
tree5daa1044b76977cbebbd0168ead3cc666c92deab /gnu/packages/check.scm
parent1f7f16dcedb9703981acc47e5677d7817b39740f (diff)
downloadguix-5e61de242156cdb3314abac168d9682ca7a4c28f.tar.gz
gnu: python-testpath: Remove incorrect #:imported-modules.
Fixes <https://bugs.gnu.org/39298>.
Reported by Clément Lassieur <clement@lassieur.org>
and Ricardo Wurmus <rekado@elephly.net>.

This pacakge would import (srfi srfi-1) from the host Guile, leading to
build failures when the host Guile is 3.0.

* gnu/packages/check.scm (python-testpath)[arguments]: Remove incorrect
 #:imported-modules.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm4
1 files changed, 1 insertions, 3 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index e10e684d32..eb2e2d62e2 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -26,7 +26,7 @@
 ;;; Copyright © 2017 ng0 <ng0@n0.is>
 ;;; Copyright © 2015, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2016, 2017, 2018, 2019, 2020 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2017, 2018 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2017, 2018, 2020 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
 ;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
 ;;; Copyright © 2019 Chris Marusich <cmmarusich@gmail.com>
@@ -1441,8 +1441,6 @@ C/C++, R, and more, and uploads it to the @code{codecov.io} service.")
        #:modules ((guix build python-build-system)
                   (guix build utils)
                   (srfi srfi-1))
-       #:imported-modules (,@%python-build-system-modules
-                           (srfi srfi-1))
        #:phases
        (modify-phases %standard-phases
          (delete 'install)