summary refs log tree commit diff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2020-07-27 10:00:48 +0200
committerMarius Bakke <marius@gnu.org>2020-07-30 00:57:28 +0200
commitfdc61e32601776045eb51ac9d86e38a53adb0b7e (patch)
tree53a7e197550d0c1f763e286af0f840f43c1a2706 /gnu/packages/check.scm
parent882979023e1a4f83ee7df8b576c39ea50e5d8c00 (diff)
downloadguix-fdc61e32601776045eb51ac9d86e38a53adb0b7e.tar.gz
gnu: Add python-hypothesmith.
* gnu/packages/check.scm (python-hypothesmith): New variable.

Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index ab1839e0a2..eb12383887 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1853,6 +1853,29 @@ seamlessly into your existing Python unit testing work flow.")
        `(("python2-enum34" ,python2-enum34)
          ,@(package-propagated-inputs hypothesis))))))
 
+(define-public python-hypothesmith
+  (package
+    (name "python-hypothesmith")
+    (version "0.1.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "hypothesmith" version))
+       (sha256
+        (base32
+         "09331sspknv459xcyn1k0lx5flqlc6gmnwp9370pfvg4kg1zmss6"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-hypothesis" ,python-hypothesis-5.23)
+       ("python-lark-parser" ,python-lark-parser)
+       ("python-libcst" ,python-libcst)))
+    (home-page "https://github.com/Zac-HD/hypothesmith")
+    (synopsis "Strategies for generating Python programs")
+    (description
+     "This package contains hypothesis strategies for generating Python
+programs, something like CSmith, a random generator of C programs.")
+    (license license:mpl2.0)))
+
 (define-public python-lit
   (package
     (name "python-lit")