summary refs log tree commit diff
path: root/gnu/packages/chemistry.scm
diff options
context:
space:
mode:
authorDavid Elsing <david.elsing@posteo.net>2022-10-13 21:04:19 +0000
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-10-15 12:05:15 +0200
commitf1707153984f17facac2ba67befe893e29632f7c (patch)
tree10474705acd261195cc91bf502a90ba2337be4b2 /gnu/packages/chemistry.scm
parent06358ee7158cf1c479006aa6c7eb225632422e95 (diff)
downloadguix-f1707153984f17facac2ba67befe893e29632f7c.tar.gz
gnu: Add maeparser.
* gnu/packages/chemistry.scm (maeparser): New variable.

Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/chemistry.scm')
-rw-r--r--gnu/packages/chemistry.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/chemistry.scm b/gnu/packages/chemistry.scm
index 1f76be9500..8ccf2ccf4b 100644
--- a/gnu/packages/chemistry.scm
+++ b/gnu/packages/chemistry.scm
@@ -751,3 +751,23 @@ calculating @acronym{SASAs, solvent accessible surface areas}.  By default Lee
 can be parameterized to arbitrary precision, and for high resolution versions
 of the algorithms, the calculations give identical results.")
     (license license:expat)))
+
+(define-public maeparser
+  (package
+    (name "maeparser")
+    (version "1.3.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/schrodinger/maeparser")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1yv4y5hn49fhylziigsg922bb244lb57p69r7vg9q899zd3l5b7l"))))
+    (build-system cmake-build-system)
+    (inputs (list boost zlib))
+    (home-page "https://github.com/schrodinger/maeparser")
+    (synopsis "Maestro file parser")
+    (description "maeparser is a parser for Schrodinger Maestro files.")
+    (license license:expat)))