summary refs log tree commit diff
path: root/gnu/packages/chez.scm
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2022-11-17 19:45:31 -0500
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-11-20 02:22:18 +0100
commitd9f51000cac9c2b5f42c966d35b1123371a1323f (patch)
tree666b161d38a0a17a7ee973bea130b8543cffe778 /gnu/packages/chez.scm
parentfca5e1a507b20939387fada4a7bcbae7bc3bbbe7 (diff)
downloadguix-d9f51000cac9c2b5f42c966d35b1123371a1323f.tar.gz
gnu: chez-scheme-for-racket: Support riscv64.
Use the new native backend instead of "portable bytecode".

* gnu/packages/chez.scm (target-chez-arch): Support riscv64-linux-gnu.
(%chez-features-table): Likewise.

Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/chez.scm')
-rw-r--r--gnu/packages/chez.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index 7025a71b94..0d22e2e20f 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -104,7 +104,7 @@ Scheme machine types, or '#f' if none is defined."
    ((target-ppc32? system)
     "ppc32")
    ((target-riscv64? system)
-    #f)
+    "rv64")
    (else
     #f)))
 
@@ -170,6 +170,7 @@ in Chez Scheme machine types, or '#f' if none is defined."
      ("a6" threads bootstrap-bootfiles)
      ("arm32" bootstrap-bootfiles)
      ("arm64" . #f)
+     ("rv64" . #f)
      ("ppc32" threads))
     ;; Hurd
     ("gnu"