summary refs log tree commit diff
path: root/gnu/packages/cmake.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-05-22 07:41:45 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-05-22 17:16:40 +0300
commitf037673c3133ae7453794f1f62eecebf9d06b092 (patch)
treee73e3aa70faba0bdd1dd658b941e9aab0995dd7f /gnu/packages/cmake.scm
parent6b84d396e0ea0b3fea6b8740c2f7e9c6a8332d2a (diff)
downloadguix-f037673c3133ae7453794f1f62eecebf9d06b092.tar.gz
gnu: cmake: Delete Emacs library.
* gnu/packages/finance.scm (cmake)[arguments]: Delete Emacs library.
Diffstat (limited to 'gnu/packages/cmake.scm')
-rw-r--r--gnu/packages/cmake.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index e9fa866411..c8f6f77b3a 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -85,6 +85,12 @@
            " --exclude-regex ^\\(" (string-join skipped-tests "\\|") "\\)$")))
        #:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'split-package
+           ;; Remove files that have been packaged in other package recipes.
+           (lambda _
+             (delete-file "Auxiliary/cmake-mode.el")
+             (substitute* "Auxiliary/CMakeLists.txt"
+               ((".*cmake-mode.el.*") ""))))
          (add-before 'configure 'patch-bin-sh
            (lambda _
              ;; Replace "/bin/sh" by the right path in... a lot of