summary refs log tree commit diff
path: root/gnu/packages/cobol.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-02-22 13:36:56 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-22 18:39:55 +0200
commitc97de01740ad336efba5830def0907f3daa9c0b8 (patch)
tree3268a42d0e6c5f7ebf0a303826f7aa5d2403dd6b /gnu/packages/cobol.scm
parent59ef52ccb296da012e23a2715b7ac40d31665061 (diff)
downloadguix-c97de01740ad336efba5830def0907f3daa9c0b8.tar.gz
gnu: gnucobol: Remove pregenerated files.
* gnu/packages/cobol.scm (gnucobol)[source]: Add snippet to remove some
pregenerated files.
[native-inputs]: Add bison, flex.

Change-Id: I1b08b1a10505808527fcee4d136668cbdc504fee
Diffstat (limited to 'gnu/packages/cobol.scm')
-rw-r--r--gnu/packages/cobol.scm20
1 files changed, 17 insertions, 3 deletions
diff --git a/gnu/packages/cobol.scm b/gnu/packages/cobol.scm
index b864dfff0f..9e9be5122a 100644
--- a/gnu/packages/cobol.scm
+++ b/gnu/packages/cobol.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2017, 2018, 2021-2023 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017, 2018, 2021-2024 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -23,7 +23,9 @@
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix gexp)
+  #:use-module (gnu packages bison)
   #:use-module (gnu packages dbm)
+  #:use-module (gnu packages flex)
   #:use-module (gnu packages multiprecision)
   #:use-module (gnu packages ncurses)
   #:use-module (gnu packages perl)
@@ -42,7 +44,17 @@
                version ".tar.xz"))
         (sha256
          (base32
-          "1qifkkrmscc5csri1l4rm9pbik74c3pc5za1rzx7jizddks8md1v"))))
+          "1qifkkrmscc5csri1l4rm9pbik74c3pc5za1rzx7jizddks8md1v"))
+        (snippet
+         #~(begin (use-modules (guix build utils))
+                  ;; Remove some files generated by bison and flex.
+                  (for-each delete-file
+                            '("cobc/parser.c"
+                              "cobc/parser.h"
+                              "cobc/ppparse.c"
+                              "cobc/ppparse.h"
+                              "cobc/pplex.c"
+                              "cobc/scanner.c"))))))
     (arguments
      (list
        #:configure-flags
@@ -62,7 +74,9 @@
              (lambda _ (setenv "TERM" "xterm-256color"))))
        #:test-target "checkall"))
     (native-inputs
-     `(("perl" ,perl)
+     `(("bison" ,bison)
+       ("flex" ,flex)
+       ("perl" ,perl)
        ("newcob" ,(origin
                     (method url-fetch)
                     (uri "https://www.itl.nist.gov/div897/ctg/suites/newcob.val.Z")