summary refs log tree commit diff
path: root/gnu/packages/code.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-05-09 14:43:04 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-05-09 21:13:28 +0200
commit38878020b03c29baed4282e53c7a1fe8c1e7e148 (patch)
treef61700138dbbdb5056b5dec7b3cd80b3c75712ec /gnu/packages/code.scm
parent6c2180f5d02687f6aa1a5931b29827469bdc0ba0 (diff)
downloadguix-38878020b03c29baed4282e53c7a1fe8c1e7e148.tar.gz
gnu: cloc: Update to 1.82.
* gnu/packages/code.scm (cloc): Update to 1.82.
[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/code.scm')
-rw-r--r--gnu/packages/code.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/code.scm b/gnu/packages/code.scm
index 09cca5d52e..51fc2189c8 100644
--- a/gnu/packages/code.scm
+++ b/gnu/packages/code.scm
@@ -212,16 +212,16 @@ COCOMO model or user-provided parameters.")
 (define-public cloc
   (package
     (name "cloc")
-    (version "1.80")
+    (version "1.82")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append
-             "https://github.com/AlDanial/cloc/releases/download/v" version
-             "/cloc-" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/AlDanial/cloc.git")
+             (commit version)))
+       (file-name (git-file-name name version))
        (sha256
-        (base32
-         "0rqxnaskg5b736asyzfda1113zvpkajyqjf49vl9wgzf1r9m6bq8"))))
+        (base32 "0fsz07z0slfg58512fmnlj8pnxkc360bgf7fclg60v9clvcjbjsw"))))
     (build-system gnu-build-system)
     (inputs
      `(("coreutils" ,coreutils)