summary refs log tree commit diff
path: root/gnu/packages/code.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-09-24 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-09-24 02:00:00 +0200
commitb2b74114667c7596aee9cde1898bd5c64db4eecc (patch)
treee21d674bacd6cf6605b48e8339e7f3113cb07173 /gnu/packages/code.scm
parent974b04ab8063382f3a91b0cf5e46bac6e0238672 (diff)
downloadguix-b2b74114667c7596aee9cde1898bd5c64db4eecc.tar.gz
gnu: astyle: Update to 3.4.8.
* gnu/packages/code.scm (astyle): Update to 3.4.8.
[arguments]: Don't explicitly return #t from phases.
Diffstat (limited to 'gnu/packages/code.scm')
-rw-r--r--gnu/packages/code.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/code.scm b/gnu/packages/code.scm
index a982e111e9..769b5bb3cc 100644
--- a/gnu/packages/code.scm
+++ b/gnu/packages/code.scm
@@ -835,15 +835,14 @@ Objective@tie{}C, D, Java, Pawn, and Vala).  Features:
 (define-public astyle
   (package
     (name "astyle")
-    (version "3.1")
+    (version "3.4.8")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "mirror://sourceforge/astyle/astyle/astyle%20"
                            version "/astyle_"  version "_linux.tar.gz"))
        (sha256
-        (base32
-         "1ms54wcs7hg1bsywqwf2lhdfizgbk7qxc9ghasxk8i99jvwlrk6b"))))
+        (base32 "1ms54wcs7hg1bsywqwf2lhdfizgbk7qxc9ghasxk8i99jvwlrk6b"))))
     (build-system gnu-build-system)
     (arguments
      `(#:tests? #f                      ;no tests
@@ -856,7 +855,7 @@ Objective@tie{}C, D, Java, Pawn, and Vala).  Features:
        #:phases
        (modify-phases %standard-phases
          (replace 'configure
-           (lambda _ (chdir "build/gcc") #t))
+           (lambda _ (chdir "build/gcc")))
          (add-after 'install 'install-libs
            (lambda* (#:key outputs #:allow-other-keys)
              ;; Libraries and includes are not installed by default
@@ -881,8 +880,7 @@ Objective@tie{}C, D, Java, Pawn, and Vala).  Features:
                 (lambda (sofile)
                   (make-so-link sofile "(\\.[0-9]){3}$")  ;; link .so
                   (make-so-link sofile "(\\.[0-9]){2}$")) ;; link .so.3
-                (find-files libdir "lib.*\\.so\\..*")))
-             #t)))))
+                (find-files libdir "lib.*\\.so\\..*"))))))))
     (home-page "https://astyle.sourceforge.net/")
     (synopsis "Source code indenter, formatter, and beautifier")
     (description