summary refs log tree commit diff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-07-01 17:24:33 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-07-02 01:06:31 +0200
commit1290855490baf03944dc85d8353c2b8cedac5256 (patch)
treec7e6f07402f849cce68fd5f0e3383720936eca55 /gnu/packages/commencement.scm
parent742f2deaa385e45e08264c6e41f2929e87319f66 (diff)
downloadguix-1290855490baf03944dc85d8353c2b8cedac5256.tar.gz
gnu: linux-libre-headers: Update to 4.19.56.
* gnu/packages/linux.scm (linux-libre-headers-4.14.67): Rename to ...
(linux-libre-headers-4.19.56): ... this.  Adjust hash accordingly.
(linux-libre-headers): Set to LINUX-LIBRE-HEADERS-4.19.56.
* gnu/packages/commencement.scm (linux-libre-headers-boot0)[native-inputs]:
Add FLEX-BOOT0 and BISON-BOOT0.
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 8a0e1c3cb1..230b63364a 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -1710,6 +1710,7 @@ exec " gcc "/bin/" program
 
 (define bison-boot0
   ;; This Bison is needed to build MiG so we need it early in the process.
+  ;; Recent versions of Linux-Libre headers also depend on this.
   (let* ((bison (package (inherit bison)
                   (propagated-inputs `(("m4" ,m4)))
                   (inputs '())                    ;remove Flex...
@@ -1735,7 +1736,7 @@ exec " gcc "/bin/" program
       (native-inputs `(("perl" ,perl-boot0))))))
 
 (define flex-boot0
-  ;; This Flex is needed to build MiG.
+  ;; This Flex is needed to build MiG as well as Linux-Libre headers.
   (let* ((flex (package (inherit flex)
                  (native-inputs `(("bison" ,bison-boot0)))
                  (propagated-inputs `(("m4" ,m4)))
@@ -1760,6 +1761,10 @@ exec " gcc "/bin/" program
                            ,@(package-arguments linux-libre-headers)))
               (native-inputs
                `(("perl" ,perl-boot0)
+
+                 ;; Flex and Bison are required since version 4.16.
+                 ("flex" ,flex-boot0)
+                 ("bison" ,bison-boot0)
                  ,@(%boot0-inputs)))))))
 
 (define gnumach-headers-boot0