summary refs log tree commit diff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorJakub Kądziołka <kuba@kadziolka.net>2020-07-20 18:19:24 +0200
committerJakub Kądziołka <kuba@kadziolka.net>2020-07-23 21:39:20 +0200
commit9a74a7db8626bc139307d115f5cec2648f5273ad (patch)
tree5d216790b0c385a21482b23c439d3af38ea3969a /gnu/packages/commencement.scm
parent7cde865f12dd67e55946a52a21103e71f447eced (diff)
downloadguix-9a74a7db8626bc139307d115f5cec2648f5273ad.tar.gz
gnu: glibc-intermediate: Don't include native-gcc in inputs.
As the comment explains, this is only necessary when building with
--enable-obsolete-rpc, which we aren't using anymore.

* gnu/packages/commencement.scm
  (glibc-final-with-bootstrap-bash)[inputs]: Remove native-gcc.
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm3
1 files changed, 0 insertions, 3 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index ecd807355c..5ab4df612a 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -3303,9 +3303,6 @@ memoized as a function of '%current-system'."
              `(("mig" ,mig-boot0))
              '())
 
-       ;; A native GCC is needed to build `cross-rpcgen'.
-       ("native-gcc" ,@(assoc-ref (%boot0-inputs) "gcc"))
-
        ;; Here, we use the bootstrap Bash, which is not satisfactory
        ;; because we don't want to depend on bootstrap tools.
        ("static-bash" ,@(assoc-ref (%boot0-inputs) "bash"))))))