summary refs log tree commit diff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-06-04 17:17:43 +0200
committerLudovic Courtès <ludo@gnu.org>2022-06-05 23:35:29 +0200
commitcd626983af6f85ab1ee894e9926087368f1771cd (patch)
tree5409a3e498f17ce9be233db3347195c932e92aa2 /gnu/packages/commencement.scm
parent2dae3cbeccb85d62525ff4fffd387393959edbb8 (diff)
downloadguix-cd626983af6f85ab1ee894e9926087368f1771cd.tar.gz
gnu: commencement: Fetch bootstrap tarballs from ftp.gnu.org too.
As a side effect, this ensures those tarballs are eventually archived by
Software Heritage.

* gnu/packages/commencement.scm (tcc-boot0)[source]: Add "mirror://gnu"
URL.
(gnumach-headers-boot0)[source]: Likewise.
(hurd-source-boot0): Likewise.
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm20
1 files changed, 13 insertions, 7 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 89fc325208..4baa45afca 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -463,9 +463,11 @@ $MES -e '(mescc)' module/mescc.scm -- \"$@\"
     (version "0.9.26-1103-g6e62e0e")
     (source (origin
               (method url-fetch)
-              (uri (string-append
-                    "http://lilypond.org/janneke/mes/20191117/"
-                    "/tcc-" version ".tar.gz"))
+              (uri (list (string-append "mirror://gnu/guix/mirror/tcc-"
+                                        version ".tar.gz")
+                         (string-append
+                          "http://lilypond.org/janneke/mes/20191117/"
+                          "/tcc-" version ".tar.gz")))
               (sha256
                (base32
                 "1qbybw7mxbgkv3sazvz1v7c8byq998vk8f1h25ik8w3d2l63lxng"))))
@@ -3008,8 +3010,10 @@ memoized as a function of '%current-system'."
       (source (bootstrap-origin
                (origin
                  (method url-fetch)
-                 (uri (string-append "https://lilypond.org/janneke/hurd/"
-                                     "gnumach-" version ".tar.gz"))
+                 (uri (list (string-append "mirror://gnu/guix/mirror/gnumach-"
+                                           version ".tar.gz")
+                            (string-append "https://lilypond.org/janneke/hurd/"
+                                           "gnumach-" version ".tar.gz")))
                  (sha256
                   (base32
                    "006i0zgwy81vxarpfm12vip4q6i5mgmi5mmy5ldvxp5hx9h3l0zg")))))
@@ -3033,8 +3037,10 @@ memoized as a function of '%current-system'."
     (bootstrap-origin
      (origin
        (method url-fetch)
-       (uri (string-append "https://lilypond.org/janneke/hurd/"
-                           "hurd-v" version ".tar.gz"))
+       (uri (list (string-append "mirror://gnu/guix/mirror/hurd-v"
+                                 version ".tar.gz")
+                  (string-append "https://lilypond.org/janneke/hurd/"
+                                 "hurd-v" version ".tar.gz")))
        (sha256
         (base32
          "0bq2q2jisxcy0kgcm6rz0z2fddwxxm7azsama7li28a2m08kdpzy"))))))