summary refs log tree commit diff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-03-09 10:47:44 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-03-24 20:57:29 +0200
commitf08b070019a3c1697bb0b4a783dcd4f31243715a (patch)
tree8ff7ebfac2ba70ed44d5004192106c834c9ecb59 /gnu/packages/commencement.scm
parent6dd338ee1b02503f0baf9480065ae69ba520154e (diff)
downloadguix-f08b070019a3c1697bb0b4a783dcd4f31243715a.tar.gz
gnu: findutils-boot0: Fix test suite on some systems.
This is a follow-up to 3a0c7e7d1e9b4e0053f3dfa266c69bcc5e7ac61e.

* gnu/packages/commencement.scm (findutils-boot0)[arguments]: Only add
custom 'skip-fnmatch-test phase on x86_64-linux and i686-linux.
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm19
1 files changed, 11 insertions, 8 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index f6bfc27843..7c39a84008 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -2512,14 +2512,17 @@ exec " gcc "/bin/" program
               ,flags))
            ((#:phases phases '%standard-phases)
             `(modify-phases ,phases
-               (add-before 'check 'skip-fnmatch-test
-                 (lambda _
-                   ;; 'test-fnmatch' fails when using glibc-mesboot@2.16, due
-                   ;; to incorrect handling of the [:alpha:] regexp character
-                   ;; class.  Ignore it.
-                   (substitute* "gnulib-tests/Makefile"
-                     (("^XFAIL_TESTS =")
-                      "XFAIL_TESTS = test-fnmatch ")))))))))))
+              ;; 'test-fnmatch' fails when using glibc-mesboot@2.16, due
+              ;; to incorrect handling of the [:alpha:] regexp character
+              ;; class.  Ignore it.
+              ,@(if (string=? (%current-system)
+                              (or "x86_64-linux" "i686-linux"))
+                  '((add-before 'check 'skip-fnmatch-test
+                      (lambda _
+                        (substitute* "gnulib-tests/Makefile"
+                          (("^XFAIL_TESTS =")
+                           "XFAIL_TESTS = test-fnmatch ")))))
+                  '()))))))))
 
 (define file
   (package