summary refs log tree commit diff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
authorZheng Junjie <873216071@qq.com>2023-06-14 22:31:43 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-06-14 22:34:17 +0300
commit09449ef6f6359c9621e512b323bc37d43a366e24 (patch)
tree16561384f9f6da93e03b23c06f30ea6a12c0e0df /gnu/packages/cpp.scm
parent10186bc291580a5a3403739eb4623c2ba63c0190 (diff)
downloadguix-09449ef6f6359c9621e512b323bc37d43a366e24.tar.gz
gnu: psascan: Do not build with "-march=native".
* gnu/packages/cpp.scm (psascan)[origin]: Add 'snippet'.
[properties]: New field.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 365b15a3b9..39a34c20dd 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -30,7 +30,7 @@
 ;;; Copyright © 2022 Attila Lendvai <attila@lendvai.name>
 ;;; Copyright © 2022 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2022 David Elsing <david.elsing@posteo.net>
-;;; Copyright © 2022 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2022, 2023 Zheng Junjie <873216071@qq.com>
 ;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2023 Sughosha <Sughosha@proton.me>
 ;;; Copyright © 2023 Artyom V. Poptsov <poptsov.artyom@gmail.com>
@@ -1173,7 +1173,11 @@ parsers according to a Parsing Expression Grammar (PEG).")
                                   "/pSAscan-" version ".tar.bz2"))
               (sha256
                (base32
-                "1cphk4gf202nzkxz6jdjzls4zy27055gwpm0r8cn99gr6c8548cy"))))
+                "1cphk4gf202nzkxz6jdjzls4zy27055gwpm0r8cn99gr6c8548cy"))
+              (modules '((guix build utils)))
+              (snippet '(begin (substitute* '("src/Makefile"
+                                              "tools/delete-bytes-255/Makefile")
+                                 (("-march=native") ""))))))
     (build-system gnu-build-system)
     (arguments
      (list
@@ -1187,6 +1191,7 @@ parsers according to a Parsing Expression Grammar (PEG).")
               (install-file "psascan"
                             (string-append #$output "/bin")))))))
     (inputs (list libdivsufsort))
+    (properties '((tunable? . #t)))
     (home-page "https://www.cs.helsinki.fi/group/pads/pSAscan.html")
     (synopsis "Parallel external memory suffix array construction")
     (description "This package contains an implementation of the parallel