summary refs log tree commit diff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-04-11 18:24:09 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-04-12 14:18:13 +0200
commit3ff587f8b092bcef5a54203a651796f4ec473111 (patch)
treed26f7574021d1fb429b71424674c3bbd2a6b52ef /gnu/packages/cpp.scm
parenta3bfb867380f1e5ce157334d7d9877297ef509ab (diff)
downloadguix-3ff587f8b092bcef5a54203a651796f4ec473111.tar.gz
gnu: abseil-cpp-20200923.3: Fix build failure.
* gnu/packages/cpp.scm (abseil-cpp-20200923.3)[arguments]: Add phase 'fix-max
to add a missing type cast.
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 6b76b6f2b8..3e52b4ec78 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -1048,6 +1048,11 @@ point and then, after each tween step, plugging back the result.")
                                "-DCMAKE_EXE_LINKER_FLAGS=-lgtest -lpthread -lgmock")
        #:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'fix-max
+           (lambda _
+             (substitute* "absl/debugging/failure_signal_handler.cc"
+               (("std::max\\(SIGSTKSZ, 65536\\)")
+                "std::max<size_t>(SIGSTKSZ, 65536)"))))
          (add-before 'configure 'remove-gtest-check
            ;; The CMakeLists fails to find our googletest for some reason, but
            ;; it works nonetheless.