summary refs log tree commit diff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2023-10-13 14:17:35 +0000
committerLudovic Courtès <ludo@gnu.org>2023-10-14 22:41:44 +0200
commit4fbfe6c4cecd9f0d76ea884db0f5d46c5e28e6ac (patch)
tree478b145039f2a1ad7838f5f4fb67b82b6f2c5cc7 /gnu/packages/cpp.scm
parentb475b511d30b6dc829a8eb93168c5e586c4bf750 (diff)
downloadguix-4fbfe6c4cecd9f0d76ea884db0f5d46c5e28e6ac.tar.gz
gnu: Add taskflow.
* gnu/packages/cpp.scm (taskflow): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 7d9eb2a264..f3f6d8df64 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -38,6 +38,7 @@
 ;;; Copyright © 2023 Liliana Marie Prikler <liliana.prikler@gmail.com>
 ;;; Copyright © 2023 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
 ;;; Copyright © 2023 Foundation Devices, Inc. <hello@foundationdevices.com>
+;;; Copyright © 2023 Paul A. Patience <paul@apatience.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1039,6 +1040,28 @@ Model and CSP-like channels.  The goal of SObjectizer is to simplify
 development of concurrent and multithreaded applications in C++.")
     (license license:bsd-3)))
 
+(define-public taskflow
+  (package
+    (name "taskflow")
+    (version "3.6.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/taskflow/taskflow")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1cv74l181137lchc1rxygcg401cnq216ymq5qz2njsw99j342br3"))))
+    (build-system cmake-build-system)
+    (home-page "https://taskflow.github.io/")
+    (synopsis
+     "General-purpose parallel and heterogeneous task programming system")
+    (description
+     "Taskflow is a C++ library for writing parallel and heterogeneous task
+programs.")
+    (license license:expat)))
+
 (define-public tweeny
   (package
     (name "tweeny")