summary refs log tree commit diff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2021-03-11 20:53:15 +0000
committerLudovic Courtès <ludo@gnu.org>2021-03-19 22:32:40 +0100
commit6457985e39d794c0f44d953d475aa19c41025d00 (patch)
tree91b7a61e434fdab56399c251adfbbe96e283276f /gnu/packages/cpp.scm
parentc4d616f7c665921e1329c75cd2d0cf05094b1306 (diff)
downloadguix-6457985e39d794c0f44d953d475aa19c41025d00.tar.gz
gnu: abseil-cpp: Patch sterror_test.
* gnu/packages/patches/abseil-cpp-fix-gtest.patch: Renamed file.
* gnu/packages/patches/abseil-cpp-fix-strerror_test.patch: New file.
* gnu/local.mk (dist_patch_DATA): Rename / add files.
* gnu/packages/cpp.scm (abseil-cpp)[source]: Use files.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index ba361ba5ca..2233d2e993 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -689,7 +689,10 @@ point and then, after each tween step, plugging back the result.")
                (base32
                 "1p4djhm1f011ficbjjxx3n8428p8481p20j4glpaawnpsi362hkl"))
               ;; Remove after next googletest release and update.
-              (patches (search-patches "abseil-cpp-fix.patch"))))
+              (patches
+               (search-patches
+                "abseil-cpp-fix-gtest.patch"
+                "abseil-cpp-fix-strerror_test.patch"))))
     (build-system cmake-build-system)
     (arguments
      `(#:configure-flags (list "-DBUILD_SHARED_LIBS=ON"