summary refs log tree commit diff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
authorAnadon <joshua.r.marshall.1991@gmail.com>2021-01-14 08:25:01 +0100
committerLeo Prikler <leo.prikler@student.tugraz.at>2021-01-20 09:04:59 +0100
commit944aebb46abfaa16321b42a095c729a0d04ae68d (patch)
tree7a4f57dadb6066f97983e1f85d0dcc2cffb42a19 /gnu/packages/cpp.scm
parent6c5112dbb32c217abf09ff8ff9bf8c47d0aea651 (diff)
downloadguix-944aebb46abfaa16321b42a095c729a0d04ae68d.tar.gz
gnu: Add magic-enum.
* gnu/packages/cpp.scm (magic-enum): New variable.

Signed-off-by: Leo Prikler <leo.prikler@student.tugraz.at>
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 45d3faeafb..03b84efdc8 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -808,3 +808,24 @@ code will be mixed in with the actual programming logic.  This implementation
 provides a number of utilities to make coding with expected cleaner.")
     (home-page "https://tl.tartanllama.xyz/")
     (license license:cc0)))
+
+(define-public magic-enum
+  (package
+    (name "magic-enum")
+    (version "0.7.2")
+    (home-page "https://github.com/Neargye/magic_enum")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url home-page)
+                    (commit (string-append "v" version))))
+              (sha256
+               (base32
+                "07j5zdf3vkliwrcv6k663k35akn7qp23794sz2mnvkj9hbv9s8cx"))))
+    (build-system cmake-build-system)
+    (native-inputs
+     `(("gcc" ,gcc-9)))
+    (synopsis "C++17 header only library for compile time reflection of enums")
+    (description "Magic Enum offers static reflection of enums, with
+conversions to and from strings, iteration and related functionality.")
+    (license license:expat)))