summary refs log tree commit diff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-10-08 22:44:39 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 10:31:25 -0500
commitf0ce5a6051e6071178eb01f2c9be66a123f56096 (patch)
treec44ffb6cbbccdc9d6c81730d421ec7d190ca2197 /gnu/packages/cpp.scm
parentd102bd7316bc2f8fe973987eac13975ac429d50f (diff)
downloadguix-f0ce5a6051e6071178eb01f2c9be66a123f56096.tar.gz
gnu: abseil-cpp: Update to 20210324.2.
But keep the older variant for Tensorflow.

* gnu/packages/cpp.scm (abseil-cpp-20200923.3): Renamed older variant.
(abseil-cpp): New variable.
* gnu/packages/machine-learning.scm (tensorflow-lite)
[inputs]: Adjust to use the older abseil-cpp-20200923.3.
* gnu/packages/rpc.scm (grpc-1.16.1)[native-inputs]: Likewise.

Co-authored-by: Greg Hogan <code@greghogan.com>
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm23
1 files changed, 22 insertions, 1 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 77ed9e0c97..37dd5ceec4 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -765,7 +765,8 @@ other values of screen objects, by setting their values as the tween starting
 point and then, after each tween step, plugging back the result.")
     (license license:expat)))
 
-(define-public abseil-cpp
+;;; This older LTS release is kept for tensorflow.
+(define-public abseil-cpp-20200923.3
   (package
     (name "abseil-cpp")
     (version "20200923.3")
@@ -812,6 +813,26 @@ augment the C++ standard library.  The Abseil library code is collected from
 Google's C++ code base.")
     (license license:asl2.0)))
 
+(define-public abseil-cpp
+  (let ((base abseil-cpp-20200923.3))
+    (package/inherit base
+      (name "abseil-cpp")
+      (version "20210324.2")
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/abseil/abseil-cpp")
+                      (commit version)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "0g9rbhk3mwjdfxk7cscd04vm8fphd5flz9yykpgvyy1nwa34zk3x"))))
+      (arguments
+       (substitute-keyword-arguments (package-arguments base)
+         ((#:configure-flags flags)
+          `(cons* "-DBUILD_TESTING=ON"
+                  (delete "-DABSL_RUN_TESTS=ON" ,flags))))))))
+
 (define-public pegtl
   (package
     (name "pegtl")