summary refs log tree commit diff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-03-02 23:04:30 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-03-02 23:05:49 +0100
commit02366a12d0a544028055cf8a4f4dfddff2e811e0 (patch)
treede63a7e2586783583b6905ac5eb78576116e4fca /gnu/packages/cran.scm
parent11ab52888d416d9fcf33349b1f376f7e47f4cdff (diff)
downloadguix-02366a12d0a544028055cf8a4f4dfddff2e811e0.tar.gz
gnu: Add r-ztype.
* gnu/packages/cran.scm (r-ztype): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 87d0eb81e0..3ae53a61a1 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -20637,3 +20637,32 @@ samples, derivatives and function evaluations are available.  Additional
 functions for applying ZV-CV to two estimators for the normalising constant of
 the posterior distribution in Bayesian statistics are also supplied.")
     (license license:gpl2+)))
+
+(define-public r-ztype
+  (package
+    (name "r-ztype")
+    (version "0.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "ztype" version))
+       (sha256
+        (base32
+         "0brbq2rgkl4mhjbb70kkfv47lzs66k9ppfs2klavcbripirxn5fx"))))
+    (properties `((upstream-name . "ztype")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-assertthat" ,r-assertthat)
+       ("r-dplyr" ,r-dplyr)
+       ("r-ggplot2" ,r-ggplot2)
+       ("r-lubridate" ,r-lubridate)
+       ("r-magrittr" ,r-magrittr)
+       ("r-rvest" ,r-rvest)
+       ("r-stringr" ,r-stringr)))
+    (home-page "https://cran.r-project.org/web/packages/ztype/")
+    (synopsis "Run a Ztype game loaded with R functions")
+    (description
+     "How fast can you type R functions on your keyboard?  Find out by running
+a @code{zty.pe} game: export R functions as instructions to type to destroy
+opponents' vessels.")
+    (license license:gpl3)))