summary refs log tree commit diff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorCharlie Ritter <chewzerita@posteo.net>2018-03-12 10:13:04 -0400
committerMarius Bakke <mbakke@fastmail.com>2018-03-26 21:43:57 +0200
commit10487c30bca4047a07202ffea385e01e52ed6a51 (patch)
tree82767a66819862d2699f5306c55eac93b3495cf3 /gnu/packages/cran.scm
parentd7637e5ed8463d0c1ef84b1a6ef5b45205fdba26 (diff)
downloadguix-10487c30bca4047a07202ffea385e01e52ed6a51.tar.gz
gnu: Add r-callr.
* gnu/packages/cran.scm (r-callr): New variable.

Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 6bf3955fd6..b2db1af3fb 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -37,6 +37,32 @@
   #:use-module (gnu packages statistics)
   #:use-module (gnu packages web))
 
+(define-public r-callr
+  (package
+    (name "r-callr")
+    (version "2.0.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "callr" version))
+       (sha256
+        (base32
+         "0m51p39vfwldxv6h8x4y9w3laf8q9bldhfqhlcrlx3xhy3irb1bp"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-assertthat" ,r-assertthat)
+       ("r-crayon" ,r-crayon)
+       ("r-debugme" ,r-debugme)
+       ("r-r6" ,r-r6)
+       ("r-testthat" ,r-testthat)))
+    (home-page "https://github.com/r-lib/callr#readme")
+    (synopsis "Call R from R")
+    (description
+     "It is sometimes useful to perform a computation in a separate R process,
+without affecting the current R process at all.  This packages does exactly
+that.")
+    (license license:expat)))
+
 (define-public r-readxl
   (package
     (name "r-readxl")