summary refs log tree commit diff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorAfkhami, Navid <Navid.Afkhami@mdc-berlin.de>2023-11-03 14:27:42 +0000
committerRicardo Wurmus <rekado@elephly.net>2023-11-03 23:39:57 +0100
commit10d728139dcbe28009153e3e6d6f440a917140ab (patch)
treec8c186db7acf395163780de0e1b64fc1af67155d /gnu/packages/cran.scm
parent479fdc8451f0b84021821d49b1b546ebb8f53406 (diff)
downloadguix-10d728139dcbe28009153e3e6d6f440a917140ab.tar.gz
gnu: Add r-ggbreak.
* gnu/packages/cran.scm (r-ggbreak): New variable.

Change-Id: I27d62d0110fb56e77dc8cf82581adb6259317c2d
Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index a838584618..1a5189cbca 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -856,6 +856,27 @@ dumbbell charts, the ability to encircle points and coordinate-system-based
 text annotations.")
     (license license:agpl3)))
 
+(define-public r-ggbreak
+  (package
+    (name "r-ggbreak")
+    (version "0.1.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "ggbreak" version))
+       (sha256
+        (base32 "14rx16v66xd0fjlywi89dq9dbw41zn7hpq14wgvf0178cxdp2fw4"))))
+    (properties `((upstream-name . "ggbreak")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-aplot r-ggfun r-ggplot2 r-ggplotify r-rlang))
+    (native-inputs (list r-knitr))
+    (home-page "https://github.com/YuLab-SMU/ggbreak")
+    (synopsis "Set axis break for ggplot2")
+    (description
+     "This package provides an implementation of scale functions for setting
+axis breaks of a ggplot.")
+    (license license:artistic2.0)))
+
 (define-public r-ggdist
   (package
     (name "r-ggdist")