summary refs log tree commit diff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-02-11 00:35:38 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-02-11 01:03:21 +0100
commit213ee6574286eef61b34df0d9b40287ee7152e41 (patch)
tree11fc738749d08701166c797a80c44ace23d3af25 /gnu/packages/cran.scm
parentf3d511cc91dfb9ec1c869b77944dd652aca392fa (diff)
downloadguix-213ee6574286eef61b34df0d9b40287ee7152e41.tar.gz
gnu: Add r-seuratobject.
* gnu/packages/cran.scm (r-seuratobject): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 19aafd6c50..58c6a902e2 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -25857,6 +25857,35 @@ as allowing spectra with different resolutions.")
 data to rasters.  It speeds up plotting of data with millions of points.")
     (license license:gpl3+)))
 
+(define-public r-seuratobject
+  (package
+    (name "r-seuratobject")
+    (version "4.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "SeuratObject" version))
+       (sha256
+        (base32
+         "03k27z7g76wy7mfja2cpxq183xk0906k9gxb2j6p1zw341gv4gii"))))
+    (properties `((upstream-name . "SeuratObject")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-matrix" ,r-matrix)
+       ("r-rcpp" ,r-rcpp)
+       ("r-rcppeigen" ,r-rcppeigen)
+       ("r-rlang" ,r-rlang)
+       ("r-sctransform" ,r-sctransform)))
+    (home-page "https://satijalab.org/seurat")
+    (synopsis "Data structures for single cell data")
+    (description
+     "This package defines S4 classes for single-cell genomic data and
+associated information, such as dimensionality reduction embeddings,
+nearest-neighbor graphs, and spatially-resolved coordinates.  It provides data
+access methods and R-native hooks to ensure the Seurat object is familiar to
+other R users.")
+    (license license:gpl3)))
+
 (define-public r-seurat
   (package
     (name "r-seurat")