summary refs log tree commit diff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-13 23:02:28 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-14 13:35:53 +0100
commit217cd2e3ee6b04ed2ac0ab4548106f8708367aa5 (patch)
tree8845c469d2effe81fb6a9a601728e33f1a02cad0 /gnu/packages/cran.scm
parent2fe1e66c4d2cab9922a6c98680c8d71bfc05654c (diff)
downloadguix-217cd2e3ee6b04ed2ac0ab4548106f8708367aa5.tar.gz
gnu: Add r-r-devices.
* gnu/packages/cran.scm (r-r-devices): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 495ef13628..ec001ab383 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -17296,3 +17296,33 @@ directories can be considered to have full names which consists of a name
 followed by comma-separated tags.  This adds additional flexibility to
 identify file sets and individual files.")
     (license license:lgpl2.1+)))
+
+(define-public r-r-devices
+  (package
+    (name "r-r-devices")
+    (version "2.16.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "R.devices" version))
+       (sha256
+        (base32
+         "15zlnq3g27whq26fbcy5zfl5hiddm256h4rga4frblg6wqlbkvdd"))))
+    (properties `((upstream-name . "R.devices")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-base64enc" ,r-base64enc)
+       ("r-r-methodss3" ,r-r-methodss3)
+       ("r-r-oo" ,r-r-oo)
+       ("r-r-utils" ,r-r-utils)))
+    (home-page "https://github.com/HenrikBengtsson/R.devices")
+    (synopsis "Unified handling of graphics devices")
+    (description
+     "This package provides functions for creating plots and image files in a
+unified way regardless of output format (EPS, PDF, PNG, SVG, TIFF, WMF, etc.).
+Default device options as well as scales and aspect ratios are controlled in a
+uniform way across all device types.  Switching output format requires minimal
+changes in code.  This package is ideal for large-scale batch processing,
+because it will never leave open graphics devices or incomplete image files
+behind, even on errors or user interrupts.")
+    (license license:lgpl2.1+)))