summary refs log tree commit diff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-14 19:34:06 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-15 15:38:51 +0100
commit257b3b812ce5ef605090c079e6e59cb5383a2100 (patch)
treec5a3cc78927a4746f949011c7a41fcc7a521b93e /gnu/packages/cran.scm
parent5aa7e882fa3f198fa8e108827162d71b0229033c (diff)
downloadguix-257b3b812ce5ef605090c079e6e59cb5383a2100.tar.gz
gnu: Add r-knn-covertree.
* gnu/packages/cran.scm (r-knn-covertree): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 3190cee592..349ea62e6b 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -18734,3 +18734,29 @@ which functions similar to its singular form, but allows the use of multiple
 statistics per bin.  Those statistics can be mapped to multiple bin
 aesthetics.")
     (license license:gpl3)))
+
+(define-public r-knn-covertree
+  (package
+    (name "r-knn-covertree")
+    (version "1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "knn.covertree" version))
+       (sha256
+        (base32
+         "0msfcmwydws7q7m5jdb0dxab0nkbl7mq5llg6v3r4qrnlvrdggvz"))))
+    (properties `((upstream-name . "knn.covertree")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-matrix" ,r-matrix)
+       ("r-rcpp" ,r-rcpp)
+       ("r-rcppeigen" ,r-rcppeigen)))
+    (home-page "https://github.com/flying-sheep/knn.covertree")
+    (synopsis "Accurate kNN Implementation with multiple distance measures")
+    (description
+     "Similarly to the FNN package, this package allows calculation of the k
+nearest neighbors (kNN) of a data matrix.  The implementation is based on
+cover trees introduced by Alina Beygelzimer, Sham Kakade, and John
+Langford (2006) @url{doi:10.1145/1143844.1143857}.")
+    (license license:agpl3+)))