summary refs log tree commit diff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-13 18:28:36 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-13 22:41:38 +0100
commit369e1bb6a89695280b4a47acdd3ac9eb4f935085 (patch)
treee37fbfdbd4c51d68ca1341b3158f3f13041d0a90 /gnu/packages/cran.scm
parent322e8d85798f32bc0a4f5bf30d4896931046780d (diff)
downloadguix-369e1bb6a89695280b4a47acdd3ac9eb4f935085.tar.gz
gnu: Add r-showtextdb.
* gnu/packages/cran.scm (r-showtextdb): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 2838dcb37a..c4f1586f64 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -16463,3 +16463,25 @@ server-side.")
      "This is a package to simplify loading of system fonts and Google Fonts
 into R, in order to support other packages.")
     (license license:gpl2)))
+
+(define-public r-showtextdb
+  (package
+    (name "r-showtextdb")
+    (version "2.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "showtextdb" version))
+       (sha256
+        (base32
+         "1qwwj9x2jvadvwn60h75k99c9xi7yhqjsgaakahz5paxgj583bsh"))))
+    (properties `((upstream-name . "showtextdb")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-sysfonts" ,r-sysfonts)))
+    (home-page "https://cran.r-project.org/web/packages/showtextdb/")
+    (synopsis "Font files for the 'showtext' package")
+    (description
+     "This package provides font files that can be used by the @code{showtext}
+package.")
+    (license license:asl2.0)))