summary refs log tree commit diff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-09-05 13:38:51 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-09-05 20:03:03 +0200
commit6a8469755cd63a2fd9deb617962bff22f8542485 (patch)
tree71a5e79cbdfacc2c73d0475c1caf87d52be7da08 /gnu/packages/cran.scm
parentdd954dd7436b47494c8708cefd0856bf6719ac68 (diff)
downloadguix-6a8469755cd63a2fd9deb617962bff22f8542485.tar.gz
gnu: Add r-rdpack.
* gnu/packages/cran.scm (r-rdpack): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 64dba2c9de..f09bdbd06f 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -4556,6 +4556,33 @@ Extract argument descriptions and other parts of the help pages of
 functions.")
     (license license:gpl2+)))
 
+(define-public r-rdpack
+  (package
+    (name "r-rdpack")
+    (version "0.9-0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "Rdpack" version))
+       (sha256
+        (base32
+         "067w0w6kza0hkzcnx58danl83yfvl9yjacr47mnid2bg856gdd1b"))))
+    (properties `((upstream-name . "Rdpack")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-bibtex" ,r-bibtex)
+       ("r-gbrd" ,r-gbrd)))
+    (home-page "https://github.com/GeoBosh/Rdpack")
+    (synopsis "Update and manipulate Rd documentation objects")
+    (description
+     "This package provides functions for manipulation of R documentation
+objects, including functions @code{reprompt()} and @code{ereprompt()} for
+updating Rd documentation for functions, methods and classes; it also includes
+Rd macros for citations and import of references from bibtex files for use in
+Rd files and roxygen2 comments, as well as many functions for manipulation of
+references and Rd files.")
+    (license license:gpl2+)))
+
 (define-public r-writexl
   (package
     (name "r-writexl")