summary refs log tree commit diff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-08-14 21:55:06 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-08-17 17:26:09 +0200
commit71be51d5310ec47ebfe49dabefd52fab23123ad4 (patch)
tree79ea3da700b5e480d71373eda20bee21aa992fef /gnu/packages/cran.scm
parent18a16ceb7c993fa043215fbf51f520cde87ca20d (diff)
downloadguix-71be51d5310ec47ebfe49dabefd52fab23123ad4.tar.gz
gnu: Add r-reshape.
* gnu/packages/cran.scm (r-reshape): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 637ddfe4f0..fa75317e94 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -453,3 +453,25 @@ statistical functions and other utilities to ease their usage.")
      "This package provides tools for pretty, human readable formatting of
 quantities.")
     (license license:expat)))
+
+(define-public r-reshape
+  (package
+    (name "r-reshape")
+    (version "0.8.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "reshape" version))
+       (sha256
+        (base32
+         "1f1ngalc22knhdm9djv1m6abnjqpv1frdzxfkpakhph2l67bk7fq"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-plyr" ,r-plyr)
+       ("r-rcpp" ,r-rcpp)))
+    (home-page "http://had.co.nz/reshape")
+    (synopsis "Flexibly reshape data")
+    (description
+     "Flexibly restructure and aggregate data using just two functions:
+@code{melt} and @code{cast}.  This package provides them.")
+    (license license:expat)))