summary refs log tree commit diff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorCharlie Ritter <chewzerita@posteo.net>2018-03-12 11:03:41 -0400
committerMarius Bakke <mbakke@fastmail.com>2018-03-26 21:43:58 +0200
commit8a1ef6ac259c57e6c1940385f679d498fe2739af (patch)
tree12b1543fe574d3e43bc8930c86d465bb3286aee1 /gnu/packages/cran.scm
parent81a9d4a4221299d00dd6b974efeeca1e79e5d2a1 (diff)
downloadguix-8a1ef6ac259c57e6c1940385f679d498fe2739af.tar.gz
gnu: Add r-rvest.
* gnu/packages/cran.scm (r-rvest): New variable.

Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 0fedb70850..8a03eebcc2 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -37,6 +37,31 @@
   #:use-module (gnu packages statistics)
   #:use-module (gnu packages web))
 
+(define-public r-rvest
+  (package
+    (name "r-rvest")
+    (version "0.3.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "rvest" version))
+       (sha256
+        (base32
+         "04mv99z8dixywx96kfy4215g6ib23s7qvd77hcf9pxqxzcvqhvhd"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-httr" ,r-httr)
+       ("r-magrittr" ,r-magrittr)
+       ("r-selectr" ,r-selectr)
+       ("r-xml2" ,r-xml2)))
+    (home-page "https://github.com/hadley/rvest")
+    (synopsis "Simple web scraping for R")
+    (description
+     "@code{r-rvest} helps you scrape information from web pages.  It is
+designed to work with @code{magrittr} to make it easy to express common web
+scraping tasks, inspired by libraries like @code{BeautifulSoup}.")
+    (license license:gpl3)))
+
 (define-public r-selectr
   (package
     (name "r-selectr")