summary refs log tree commit diff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2020-04-27 11:15:38 +0200
committerRoel Janssen <roel@gnu.org>2020-04-27 11:15:38 +0200
commit91370829f4b7d043673e283466d1795143e91684 (patch)
treee0268e218148451fea509060f452e6128a3066f3 /gnu/packages/cran.scm
parent415176e89df200c0e8d4cee348bc67b739112bbb (diff)
downloadguix-91370829f4b7d043673e283466d1795143e91684.tar.gz
gnu: Add r-inum.
* gnu/packages/cran.scm (r-inum): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 86f33100f1..74e5fa2b1e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -2494,6 +2494,27 @@ and S4 methods with inlined C, C++ or Fortran code supporting @code{.C} and
     ;; Any version of the LGPL.
     (license license:lgpl3+)))
 
+(define-public r-inum
+  (package
+    (name "r-inum")
+    (version "1.0-1")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "inum" version))
+              (sha256
+               (base32
+                "16d09391l65w557dkzhhx1aqn1ljamcmjj3yh42pwq037k0r8brw"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-libcoin" ,r-libcoin)))
+    (home-page "https://cran.r-project.org/web/packages/inum/")
+    (synopsis "Interval and enum-type representation of vectors")
+    (description
+     "This package provides an enum-type representation of vectors and
+representation of intervals, including a method of coercing variables
+in data frames.")
+    (license license:gpl2)))
+
 (define-public r-bdsmatrix
   (package
     (name "r-bdsmatrix")