summary refs log tree commit diff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-09-07 12:48:23 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-09-07 12:48:23 +0200
commit987d0587dfa66b8e147fbde555d316ed2268a179 (patch)
tree7b8c4ad4466816c7fb361ee165df41f486b4aad9 /gnu/packages/cran.scm
parent336e618770d9bb70e1595666c8d25b40936e83b5 (diff)
downloadguix-987d0587dfa66b8e147fbde555d316ed2268a179.tar.gz
gnu: Add r-cmplot.
* gnu/packages/cran.scm (r-cmplot): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 9319f971bd..455a42adc6 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -9417,6 +9417,31 @@ maximal.  Both functions have the same interface as the @code{prcomp} function
 from the @code{stats} package (plus some extra parameters).")
     (license license:gpl2+)))
 
+(define-public r-cmplot
+  (package
+    (name "r-cmplot")
+    (version "3.6.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "CMplot" version))
+       (sha256
+        (base32
+         "13y05j5gsdc712fn7yvcz5nx2pbcdvl201hfb6jzpvl86qx2l0j1"))))
+    (properties `((upstream-name . "CMplot")))
+    (build-system r-build-system)
+    (home-page "https://github.com/YinLiLin/CMplot")
+    (synopsis "Circle Manhattan plot")
+    (description
+     "Circle Manhattan Plot is an R package that can lay out genome-wide
+association study P-value results in both traditional rectangular patterns,
+QQ-plot and novel circular ones.  United in only one bull's eye style plot,
+association results from multiple traits can be compared interactively,
+thereby to reveal both similarities and differences between signals.
+Additional functions include: highlight signals, a group of SNPs, chromosome
+visualization and candidate genes around SNPs.")
+    (license license:gpl2+)))
+
 (define-public r-abcoptim
   (package
     (name "r-abcoptim")