summary refs log tree commit diff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorCharlie Ritter <chewzerita@posteo.net>2018-03-12 09:56:56 -0400
committerMarius Bakke <mbakke@fastmail.com>2018-03-26 21:43:57 +0200
commit9a91c925f2e4a4d021b417729e77284dd11ca789 (patch)
tree3b2b60f48ae174ad24fe4d870b620e6b36923bbf /gnu/packages/cran.scm
parentd2a507efd92c83a9b5d38b46b3fbc406beb2e8ba (diff)
downloadguix-9a91c925f2e4a4d021b417729e77284dd11ca789.tar.gz
gnu: Add r-modelr.
* gnu/packages/cran.scm (r-modelr): New variable.

Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index d50289d722..49bd835791 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -37,6 +37,33 @@
   #:use-module (gnu packages statistics)
   #:use-module (gnu packages web))
 
+(define-public r-modelr
+  (package
+    (name "r-modelr")
+    (version "0.1.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "modelr" version))
+       (sha256
+        (base32
+         "1rqw0b583vp107zqp4h3wj51dvv4hb3wszfr1f5f48xassc53f95"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-broom" ,r-broom)
+       ("r-dplyr" ,r-dplyr)
+       ("r-lazyeval" ,r-lazyeval)
+       ("r-magrittr" ,r-magrittr)
+       ("r-purrr" ,r-purrr)
+       ("r-tibble" ,r-tibble)
+       ("r-tidyr" ,r-tidyr)))
+    (home-page "https://github.com/tidyverse/modelr")
+    (synopsis "Helper functions for modelling in pipelines")
+    (description
+     "Functions for modelling that help you seamlessly integrate modelling
+into a pipeline of data manipulation and visualisation.")
+    (license license:gpl3)))
+
 (define-public r-haven
   (package
     (name "r-haven")