summary refs log tree commit diff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-25 15:58:38 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-25 15:58:38 +0100
commita0583c0d1392a3401116faed50c7ccf534d0c4c4 (patch)
tree8870488e8153d0b667880420faadd17dd7713588 /gnu/packages/cran.scm
parentab7f1eb97abd49676f8e98e35e861f9785f0c2b2 (diff)
downloadguix-a0583c0d1392a3401116faed50c7ccf534d0c4c4.tar.gz
gnu: Add r-hierfstat.
* gnu/packages/cran.scm (r-hierfstat): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index de2337e11a..fe69ee8fc4 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -12776,3 +12776,29 @@ and dimensionality reduction.  Among other methods @code{kernlab} includes
 Support Vector Machines, Spectral Clustering, Kernel PCA, Gaussian Processes
 and a QP solver.")
     (license license:gpl2)))
+
+(define-public r-hierfstat
+  (package
+    (name "r-hierfstat")
+    (version "0.04-22")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "hierfstat" version))
+       (sha256
+        (base32
+         "1fav2v2996v5kb1ffa6v5wxfm921syxg6as034vd3j4jfhdibyfx"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-ade4" ,r-ade4)
+       ("r-adegenet" ,r-adegenet)
+       ("r-gtools" ,r-gtools)))
+    (home-page "https://cran.r-project.org/web/packages/hierfstat/")
+    (synopsis "Estimation and tests of hierarchical F-statistics")
+    (description
+     "This package allows the estimation of hierarchical F-statistics from
+haploid or diploid genetic data with any numbers of levels in the hierarchy,
+following the algorithm of Yang (Evolution, 1998, 52(4):950-956).  Functions
+are also given to test via randomisations the significance of each F and
+variance components, using the likelihood-ratio statistics G.")
+    (license license:gpl2+)))