summary refs log tree commit diff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-09-23 14:46:20 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-09-23 14:46:49 +0200
commitbdbfaf76c96f9efcf1b292b152746b2f8d176076 (patch)
tree7014bcdc086323277796b1a96c9df2b33884eb9e /gnu/packages/cran.scm
parent597f324dcd4251f47b4ab892ca1ec9359d0420e8 (diff)
downloadguix-bdbfaf76c96f9efcf1b292b152746b2f8d176076.tar.gz
gnu: Add r-logger.
* gnu/packages/cran.scm (r-logger): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b2a0bebeec..84214ad9de 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -31869,6 +31869,27 @@ regression and obtain Bayesian inference of the model via the Markov Chain
 Monte Carlo approach implemented in JAGS.")
     (license license:gpl3+)))
 
+(define-public r-logger
+  (package
+    (name "r-logger")
+    (version "0.2.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "logger" version))
+       (sha256
+        (base32 "0p607da2rdrfj9sbrrq9hpqp26nyj3imd1590c13bxskqfhv0sz8"))))
+    (properties `((upstream-name . "logger")))
+    (build-system r-build-system)
+    (native-inputs `(("r-knitr" ,r-knitr)))
+    (home-page "https://daroczig.github.io/logger/")
+    (synopsis "Lightweight and flexible logging utility")
+    (description
+     "Inspired by the the @code{futile.logger} R package and @code{logging}
+Python module, this utility provides a flexible and extensible way of
+formatting and delivering log messages with low overhead.")
+    (license license:agpl3+)))
+
 (define-public r-ggh4x
   (package
     (name "r-ggh4x")